Product Pricing not working on newest Chrome version
Incident Report for Wondersign Catalog Kiosk
Resolved
We have just released version 4.1.3 of the Chrome App to work around this issue. If your Kiosk does not display pricing information, please restart the Chromebox to install App Version 4.1.3. You can check the App Version and restart the device in the Logo Menu.

How to access the Logo Menu: https://wondersign.zendesk.com/hc/en-us/articles/209766273-How-To-Manually-Update-Restart-Your-Kiosk

We are continuing to work with Google to identify the root cause of this issue.
Posted Oct 02, 2016 - 05:51 EDT
Update
We are working with Google to resolve this issue as quickly as possible
Posted Oct 01, 2016 - 20:19 EDT
Identified
Our team is working to identify and resolve an issue with the most recent ChromeOS version 53.0.2785.144, which leads to product pricing not being shown on the product detail page.
Posted Oct 01, 2016 - 17:29 EDT