my.catalogkiosk.com is currently unavailable for some customers
Incident Report for Wondersign Catalog Kiosk
Resolved
The issue has been resolved. All systems are operational.
Posted May 26, 2020 - 13:08 EDT
Monitoring
The issue has been resolved and our team is monitoring the situation
Posted May 26, 2020 - 12:50 EDT
Identified
Our team has identified the issue and is working to implement a solution
Posted May 26, 2020 - 12:08 EDT
Investigating
Catalog App Manager (CAM) is currently unavailable for some customers. Our team is working to resolve the issue.
Posted May 26, 2020 - 12:00 EDT
This incident affected: Catalog App Manager.