Sales & support phone number unavailable
Incident Report for Wondersign Catalog Kiosk
Resolved
Wondersign’s toll-free number for sales & support (855-408-9966) is back up and running. We apologize for the inconvenience this may have caused. We have already taken steps to further improve the reliability of our call center infrastructure.
Posted Oct 18, 2017 - 15:53 EDT
Identified
Wondersign's toll-free number for sales & support (855-408-9966) is currently experiencing technical difficulties. We are - together with our call center partners - working hard to get it back to normal as quickly as possible. In the meantime, if you need to reach customer service for Wondersign Catalog Kiosk or any other Wondersign product, here are alternative ways to get in touch:

- Please send us an email at support@wondersign.com with at least your name, phone number, and a short description of the issue and we will call you right back.
- Alternatively you can call 813-925-0403 temporarily to reach our agents. You might experience longer than normal hold times.

We apologize for the inconvenience and we will update once this issue has been resolved.
Posted Oct 17, 2017 - 09:25 EDT