Support phone number currently unavailable
Incident Report for Wondersign Catalog Kiosk
Resolved
Our carrier successfully resolved the phone number issue and our phenomenal support team is back online to take your call. We apologize for the inconvenience.
Posted Jul 27, 2018 - 18:42 EDT
Investigating
Our support phone number 855-408-9966 is currently unavailable. Our carrier is working to resolve this issue. In the meantime, please contact our support team by email: support@wondersign.com
Posted Jul 27, 2018 - 13:51 EDT