Catalog App Manager slow or unresponsive
Incident Report for Catalog Kiosk
Resolved
This incident has been resolved.
Posted Jan 20, 2020 - 17:00 EST
Monitoring
Our team has implemented a fix to resolve issues with Catalog App Manager (my.catalogkiosk.com). We will continue to monitor the system closely.
Posted Jan 20, 2020 - 15:09 EST
Identified
Catalog App Manager (my.catalogkiosk.com) is currently slow or unresponsive for some users. Our team is looking into the issue and working to resolve quickly.
Posted Jan 20, 2020 - 13:52 EST
This incident affected: Catalog App Manager.